J’ai (enfin!) réussi à installer Jbrout!!

Je cherchais désespéramment à installer Jbrout, le meilleur logiciel pour taguer vos photos selon leur date et heure de prise de vue, malheureusement impossible de mettre la main sur le .deb!

Par miracle, cet après-midi, en sortant un vieil ordi du garage, j’ai trouvé un .deb de Jbrout!!

Joie de courte durée car ce dernier ne s’installe pas sur ma 18.04, pour cause de dépendances manquantes….

Préparation du dépaquetage de jbrout_0.3.359_all.deb …
Dépaquetage de jbrout (0.3.359) …
dpkg: jbrout : problèmes de dépendances, mais configuration comme demandé :
jbrout dépend de python-gtk2 ; cependant :
Le paquet python-gtk2 n’est pas installé.
jbrout dépend de python-glade2 ; cependant :
Le paquet python-glade2 n’est pas installé.
jbrout dépend de python-imaging ; cependant :
Le paquet python-imaging n’est pas installé.
jbrout dépend de python-pyexiv2 (>= 0.1.2) ; cependant :
Le paquet python-pyexiv2 n’est pas installé.
jbrout dépend de pyexiv2 ; cependant :
Le paquet exiftran n’est pas installé.

Me voilà parti dans une série de « sudo apt install…. » avec toutes les dépendances au bout…

Mais évidemment, impossible à installer!!

Parfois la mémoire étant joueuse, il m’est revenu un sombre souvenir me rappelant que la commande « sudo aptitude install » était parfois plus efficace pour installer des paquets récalcitrants….

Me voilà donc parti avec:

sudo apt install aptitude

Puis:

sudo aptitude install python-gtk2

sudo aptitude install python-glade2

sudo aptitude install python-imaging

sudo aptitude install python-pyexiv2

sudo aptitude install exiftran

le paquet python-imaging n’existant plus j’ai trouvé une solution de rechange avec

sudo aptitude install python-pil

et voilà….

 

 

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *